forums | blogs | polls | tutorials | downloads | rules | help

Aaand we're back! Again!

techiem2's picture

If you are seeing this, the site migration is complete!

There are some issues with this old Drupal version and the newer PHP version on the new server.
Add comments here with anything you run into that doesn't work so I can look into it.

The current plan is to fix what I can while working on a rebuild of the site on a newer Drupal version.
I'll let everyone know when that's ready for testing.

Techiem2 happy to hear the migration to the new servers is done. There are some issues that I noted previously with the Files and User functions.

1. Downloads from the Download directory do not show a download link it does not matter if the file is stored within Siege the Day or At an external link. However downloads of the same files from the various forums work flawlessly. I am not sure why the download links show in the forums but not in the download area.

2. New users can register with the site, by the various information that should show in there account are not visible. The user can see their user name and what they have posted but little else. I have to assume from this that the user account data is being saved correctly but can not be viewed. From an administrative point of view, I can remove people that violate system rules but can not block their IP address. I can also track what they post, but the system no longer allows me to save a shadow copy of the post that violated the rules. If I where to remove a post for rules violation I would also be forced to remove any replies to the post violation.

In both cases the information is there it just can not be viewed.
I will try a few things. and let you know

Elf

techiem2's picture

I rebuilt the node permissions. See if that fixes anything.

techiem2 wrote:
I rebuilt the node permissions. See if that fixes anything.

Sorry Techiem2 no change
Elf

It appears what is missing is the Download URL link.

Open downloads menu
select any catagory
you should see several mods if you left click any title you should see View, Edit and Outline
if you look at the edit submenu you will see about 3/4 of the way down the page Download URL and below that the link to the mod. Now the link is there but for some reason it is not being shown on the top level mod page.

Now what is odd is I used a mod stored on Siege the Day http://www.siegetheday.org/files/adepts_heroes_patch.zip copied the link to my browser and I was able to get the download link, down load the file and compare it with one that I already had and the file is the same and works. Just like if you click on the link in this post. So the files are there but for some reason are not linked to the mod's title page.

Although I was able to figure out what was missing from the down loads but not why. I was unable to find something like this for the user accounts. But I expect it must be something similar.
Techie is there some way I can access the old site so I could take screen shots of the various user menus? As pictures are better than words. I could show you what the menus looked like then and now. Not sure however if that would really help.

Elf

I know I should have asked this before but with so many things happening here and in the real world I forgot.
What is the old version of Drupal (4.5) or something else?
What is the version of PHP version on the new server?
What version of Drupal will the final Site be 6 7 or 8?
What I gather from what sol and you have told me is that we are trying to keep the old site working on the new server until the updated site is ready for action am I correct.
You must forgive me as I tend to be a but slow when it comes to software.

The only two things that I can see that are really a hindrance to the old site working on the new server is the user database menus and the fact that the download area does not display the file links.

Should we maybe ask the users here if anyone has experience with doing this?
I have been reading everything I can find on line to see if I can hunt down a fix or a place to look.
Insane Elf

bare_elf wrote:
techiem2 wrote:
I rebuilt the node permissions. See if that fixes anything.

Sorry Techiem2 no change
Elf

It appears what is missing is the Download URL link.

Open downloads menu
select any catagory
you should see several mods if you left click any title you should see View, Edit and Outline
if you look at the edit submenu you will see about 3/4 of the way down the page Download URL and below that the link to the mod. Now the link is there but for some reason it is not being shown on the top level mod page.

Now what is odd is I used a mod stored on Siege the Day http://www.siegetheday.org/files/adepts_heroes_patch.zip copied the link to my browser and I was able to get the download link, down load the file and compare it with one that I already had and the file is the same and works. Just like if you click on the link in this post. So the files are there but for some reason are not linked to the mod's title page.


Based on what I discovered above I did a bit of copy and paste work in the game patch section of the download area that appears to work nicely. I can if necessary do a copy and paste for all the download section as a temporary fix so that all you would have to work on is the The sections missing from the User Section. Then the old version of the website would be operational until you are ready to release the new site for testing. Check out the game patches section of the download area and tell me what you think. The task is simple but the number of files and my schedule it might take a bit of time to complete. Maybe several of us here could split up the work. I could right a how to and then keep track of who is doing what section.

sol77's picture

Bare elf,

I don't remember the version of Drupal but 4 or 5. Here's the rest:
Apache version 2.2.29
PHP version 5.4.24
MySQL version 5.5.42-37.1-log

I couldn't find a way to access the old site but it is still there for a few more hours. I found the shared IP, but not how to find the site from there. :/

techiem2's picture

Yeah..that's what I saw as well..

techiem2's picture

Appears to be Drupal 5.2
Server is currently:
Apache 2.2.29
PHP 5.5.25
MySQL 5.6.24

As for the new, I'll probably use whatever is current stable when I set it up.

sol77 wrote:
Bare elf,

I don't remember the version of Drupal but 4 or 5. Here's the rest:
Apache version 2.2.29
PHP version 5.4.24
MySQL version 5.5.42-37.1-log

I couldn't find a way to access the old site but it is still there for a few more hours. I found the shared IP, but not how to find the site from there. :/

techiem2's picture

From what I saw in the logs, PHP seems to be the main issue.
Drupal is using quite a few functions that have been deprecated.